Alte Eclipse und Java Projekte – java.util.Map$Entry cannot be resolved

Veröffentlicht von

Altes Java-Projekt mit Eclipse 3.7. Beim Öffnen des Projektes sind diverse Fehler im Projekt. Konkret: “The type java.util.Map$Entry cannot be resolved“. Nach etwas suchen, bin ich endlich drauf gekommen.

Das alte Projekt wurde damals mit Java 7 erstellt und benötigt damit auch die alte Java-Runtime. Diese gibt es bei Oracle im Archiv zum Download. Konfiguriert und es läuft wieder.

Die Alternative wäre natürlich, das Projekt auf eine neue Eclipse- und Java-Version upzudaten.

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.